Supplier issue: Ambassadors
Incident Report for Ingresso
Resolved
Ambassadors has contacted us to let us know the incident has been resolved and the database restored.
Posted Oct 08, 2018 - 10:47 BST
Identified
Ambassadors system is currently down due to database issues as advised by the supplier.

The list of affected events is below. We will update with any information as received by the supplier, or when access is restored.

NJVN EUGENIUS!
M7TJ Foxfinder
N64W Songs for Nobodies
Posted Oct 08, 2018 - 09:38 BST