Stripe outages
Incident Report for Ingresso
Postmortem

Stripe have updated us with more information about this outage.

On Wednesday, the Stripe API had two periods of severely degraded availability. They were 27 and 93 minutes long.

I am reaching out to apologize.

We know how important reliability is for your business. Our top priority as a company is to ensure the safe and secure handling of your transactions. We work hard to avoid problems that disrupt even a single Stripe user and we especially regret this one. We aim for Stripe to be as dependable as DNS.

We just published a preliminary root cause analysis of the incident: https://protect-us.mimecast.com/s/aYz9C9r7jPsRQgEEho2Uu4?domain=stripe.com. The very short summary is that two different database bugs and a configuration change interacted in a cascading and unforeseen way.

We don’t expect these issues to reoccur. We were already investing extensively in several projects that will make such issues very unlikely, and we are now accelerating these efforts.

We’re very grateful that you choose to use Stripe. We will work hard to make sure that we live up to your, and our own, reliability expectations in the future.

David Singleton
Stripe CTO

Posted Jul 12, 2019 - 19:34 BST

Resolved
FYI:

We have experience errors on our payment system due to Stripe outages from Jul 10, 2019 4:36:28 PM UTC to Jul 10, 2019 10:22:32 PM UTC.

Actions were taken for the transactions affected by this issue; this means that during this time, we were not able to process card payments, but were retried successfully later today.

This issue is now resolved and being monitored.

For more information check at https://status.stripe.com

On 2019-07-10, the Stripe API was degraded from 16:36–17:02 UTC, and again from 21:14–22:47 UTC. It’s now recovered. We’re working on a root cause analysis and will share it here.
Posted Jul 11, 2019 - 12:47 BST
This incident affected: White label websites.