Gaylord Texan connection down
Incident Report for Ingresso
Resolved
This incident has been resolved.
Posted Oct 24, 2022 - 16:51 BST
Investigating
We are currently looking into the cause of the issue
Posted Oct 21, 2022 - 19:42 BST
This incident affected: API.