Operational issue impacting payment connections - currently investigating
Incident Report for Ingresso
Resolved
This incident has been resolved.
Posted Nov 13, 2023 - 12:14 GMT
Investigating
We are currently investigating this issue.
Posted Nov 13, 2023 - 12:11 GMT
This incident affected: API, Reporting, and Supplier connectors.