Haymarket Affiliate Performance availability Issues
Incident Report for Ingresso
Resolved
this has now been resolved by ENTA.
Posted Sep 22, 2022 - 19:51 BST
Investigating
We are currently investigating this issue.
Posted Sep 22, 2022 - 17:30 BST
This incident affected: API and White label websites.